Computer Applications
Write a program to input a sentence. Create a new sentence by replacing each consonant with the previous letter. If the previous letter is a vowel then replace it with the next letter (i.e., if the letter is B then replace it with C as the previous letter of B is A). Other characters must remain the same. Display the new sentence.
Sample Input : ICC WORLD CUP
Sample Output : IBB VOQKC BUQ
Java
Java String Handling
26 Likes
Answer
import java.util.Scanner;
public class KboatReplaceLetters
{
public static void main(String args[]) {
Scanner in = new Scanner(System.in);
System.out.println("Enter a sentence: ");
String str = in.nextLine();
int len = str.length();
String newStr = "";
for (int i = 0; i < len; i++) {
char ch = str.charAt(i);
char chUp = Character.toUpperCase(ch);
if (chUp == 'A'
|| chUp == 'E'
|| chUp == 'I'
|| chUp == 'O'
|| chUp == 'U') {
newStr = newStr + ch;
}
else {
char prevChar = (char)(ch - 1);
char prevCharUp = Character.toUpperCase(prevChar);
if (prevCharUp == 'A'
|| prevCharUp == 'E'
|| prevCharUp == 'I'
|| prevCharUp == 'O'
|| prevCharUp == 'U') {
newStr = newStr + (char)(ch + 1);
}
else {
newStr = newStr + prevChar;
}
}
}
System.out.println(newStr);
}
}
Variable Description Table
Program Explanation
Output
Answered By
6 Likes
Related Questions
Write a program to accept a word and convert it into lower case, if it is in upper case. Display the new word by replacing only the vowels with the letter following it.
Sample Input: computer
Sample Output: cpmpvtfrConsider the sentence as given below:
Blue bottle is in Blue bag lying on Blue carpet
Write a program to assign the given sentence to a string variable. Replace the word Blue with Red at all its occurrence. Display the new string as shown below:
Red bottle is in Red bag lying on Red carpetWrite a program to input a sentence. Count and display the frequency of each letter of the sentence in alphabetical order.
Sample Input: COMPUTER APPLICATIONS
Sample Output:Character Frequency Character Frequency A 2 O 2 C 2 P 3 I 1 R 1 L 2 S 1 M 1 T 2 N 1 U 1 A 'Happy Word' is defined as:
Take a word and calculate the word’s value based on position of the letters in English alphabet. On the basis of word’s value, find the sum of the squares of its digits. Repeat the process with the resultant number until the number equals 1 (one). If the number ends with 1 then the word is called a 'Happy Word'.
Write a program to input a word and check whether it a ‘Happy Word’ or not. The program displays a message accordingly.
Sample Input: VAT
Place value of V = 22, A= 1, T = 20
[Hint: A = 1, B = 2, ----------, Z = 26]Solution:
22120 ⇒ 22 + 22 + 12 + 22 + 02 = 13
⇒ 12 + 32 = 10
⇒ 12 + 02 = 1Sample Output: A Happy Word