Computer Applications
Create a program to find out if the number entered by the user is a two, three or four digits number.
Sample input: 1023
Sample output: 1023 is a 4 digit number.
Answer
import java.util.Scanner;
public class KboatNumber
{
public static void main(String args[]) {
Scanner in = new Scanner(System.in);
System.out.print("Enter number: ");
int n = in.nextInt();
if (n >= 10 && n <= 99)
System.out.println("Two Digit Number");
else if (n >= 100 && n <= 999)
System.out.println("Three Digit Number");
else if (n >= 1000 && n <= 9999)
System.out.println("Four Digit Number");
else
System.out.println("Please enter a 2, 3 or 4 digit number");
}
}
Output
Related Questions
Find the errors in the following code and rewrite the correct version:
char m="A"; Switch ("A"); { Case 'a'; System.out.println("A"); break; Case 'b'; System.out.println("B"); break; Default: System.out.println("Not a valid option"); }
Write a program to find the number of and sum of all integers greater than 500 and less than 1000 that are divisible by 17
Write a program in Java that reads a word and checks whether it begins with a vowel or not.
Write a program in Java to read three integers and display them in descending order.