Computer Applications
Write a program in Java to store 20 numbers in a Single Dimensional Array (SDA). Display the numbers which are prime.
Sample Input:
n[0] | n[1] | n[2] | n[3] | n[4] | n[5] | … | n[16] | n[17] | n[18] | n[19] |
---|---|---|---|---|---|---|---|---|---|---|
45 | 65 | 77 | 71 | 90 | 67 | … | 82 | 19 | 31 | 52 |
Sample Output: 71, 67, 19, 31
Java
Java Arrays
232 Likes
Answer
import java.util.Scanner;
public class KboatSDAPrimeNumbers
{
public static void main(String args[]) {
Scanner in = new Scanner(System.in);
int arr[] = new int[20];
System.out.println("Enter 20 numbers");
for (int i = 0; i < arr.length; i++) {
arr[i] = in.nextInt();
}
System.out.println("Prime Numbers:");
for (int i = 0; i < arr.length; i++) {
int c = 0;
for (int j = 1; j <= arr[i]; j++) {
if (arr[i] % j == 0) {
c++;
}
}
if (c == 2)
System.out.print(arr[i] + ", ");
}
}
}
Variable Description Table
Program Explanation
Output
Answered By
96 Likes
Related Questions
Write a program in Java to store 20 temperatures in °F in a Single Dimensional Array (SDA) and display all the temperatures after converting them into °C.
Hint: (c/5) = (f - 32) / 9Write a program to accept name and total marks of N number of students in two single subscript arrays name[ ] and totalmarks[ ].
Calculate and print:
(i) The average of the total marks obtained by N number of students.
[average = (sum of total marks of all the students)/N]
(ii) Deviation of each student's total marks with the average.
[deviation = total marks of a student - average]Write a program in Java using arrays:
(a) To store the Roll No., Name and marks in six subjects for 100 students.
(b) Calculate the percentage of marks obtained by each candidate. The maximum marks in each subject are 100.
(c) Calculate the Grade as per the given criteria:Percentage Marks Grade From 80 to 100 A From 60 to 79 B From 40 to 59 C Less than 40 D Write a program in Java to store 10 numbers (including positive and negative numbers) in a Single Dimensional Array (SDA). Display all the negative numbers followed by the positive numbers without changing the order of the numbers.
Sample Input:n[0] n[1] n[2] n[3] n[4] n[5] n[6] n[7] n[8] n[9] 15 21 -32 -41 54 61 71 -19 -44 52 Sample Output: -32, -41, -19, 44, 15, 21, 54, 61, 71, 52